Author Topic: Installing SB+ PE on Universe 10.2 PE [FYI]  (Read 5460 times)

precisonline

  • President
  • Administrator
  • Rock Star
  • *****
  • Posts: 1612
    • Precision Solutions
Installing SB+ PE on Universe 10.2 PE [FYI]
« on: February 08, 2008, 05:26:21 PM »
I downloaded the SB+ 5.4.2 PE (UV/Win) from IBM today to install on top of my UV 10.2 PE installation and man, what a challenge!  The download and Windows installer went smoothly, but then I had to manually add the account to UV (which one doesn't have to do on UD) and when running SB.INITIATE the fun really began.

When I first setup the DM pointer and ran DMSECURITY SB.INITIATE it didn't seem to do anything.  It displayed a message saying it created a DM.O file (but only the first time) but then nothing after that.  (Back to the > prompt.)  Remembering from early SB+ installs (and I mean like version 2.x) that there could be some issue with file pointers I listed the VOC starting with DM and noticed that the SB.INITIATE had created a broken DMSECURITY pointer.  So I manually changed this to be a Q-pointer to the SB+ account and tried SB.INITIATE again and this time I got:

+

Program "SB.INITIATE": Line 736, Variable "NO.SYSIDS" previously undefined.  Empty string used.
 system(s) now initialized !
Press <Enter> to Continue ?
Verb "SB.LOGIN" is not in your VOC.

Figuring some other file pointer must've been broken, I listed the VOC file again and sure enough, DMSYSDEFN was a broken F pointer.   Having fixed that, I ran SB.INITIATE again and this time it looked a bit more reasonable:

Cataloging SB+ Programs ...

Writing file pointers for ...
     DMGC - cataloging all routines.
     DMGD - cataloging all routines.
     DMSH - cataloging all routines.
     DMUT - cataloging all routines.
     TUBP - cataloging all routines.
+

Well, almost.  Not sure what the + is, but it wants some activity, so I pressed <cr> and it prompted me to create a system, which seemed to work fine.   When I tried to login, I was able to authenticate just fine, but after selecting the TU.VT220 terminal emulation (and yes, I'm using SBClient) I get this mess:

Terminal Id (or * for list) (DEFAULT.TERM) : TU.VT220                         
Program "SB.LICENCE": Line 191, Unable to open the operating system file "C:\IBM\UV\SB\SB+.DEFN\DM.O/TU.INIT.EX".                                             
[ENOENT] No such file or directory                                             
Program "SB.LICENCE": Line 191, Unable to load file "TU.INIT.EX".             
Program "SB.LICENCE": Line 191, Unable to load subroutine.                     

A couple of notables.  First, if I use the DEFAULT.TERM terminal type, this does not come up.  Second, DM.O does not contain anything like TU.INIT.EX.  TU.INIT.EX appears instead in TU.BP.  This then led to a series of new challenges that made me finally select the entire TUBP.O and recatalog the works out of TUBP.  NOW I have a working account.

I'm not posting this for assistance, unless of course someone had an easier time and I just made it more difficult for myself and you have a better way to install SB+ on an existing account.  But if it's this difficult to install SB+ PE on UV normally, then the SB+ team @ IBM should be ashamed.  How do they expect this product to get any traction when it takes intimate familiarity with the files and U2 TCL commands just to make the install work?
-Kevin
Accidents "happen"; success, however, is planned and executed.