Author Topic: HOLD vs Direct Printing under RedHat Linux  (Read 4220 times)

Tom Pellitieri

  • Rock Star
  • *****
  • Posts: 224
  • Tom Pellitieri - Toledo, Ohio
HOLD vs Direct Printing under RedHat Linux
« on: January 08, 2014, 01:31:02 PM »
We've migrated our application from IBM AIX to RedHat Linux, and have run into a weird issue.  One of our reports (monthly Statements) does not print properly from the _HOLD_ file.  If I send it directly to the printer, it processes the PCL commands correctly.  If I save the job to the _HOLD_ file and spool it, all of the Escape characters are dropped, and the PCL commands appear in the output.

I have other PCL documents that process correctly (e.g., invoices with our logo).  Does anyone have any idea why spooling from the _HOLD_ file would mess this up?  It worked find under AIX.

Any advice would be appreciated.  Thanks.

--Tom Pellitieri, Toledo, Ohio

Tom Pellitieri

  • Rock Star
  • *****
  • Posts: 224
  • Tom Pellitieri - Toledo, Ohio
Re: HOLD vs Direct Printing under RedHat Linux
« Reply #1 on: January 14, 2014, 09:49:50 AM »
Well... I found a solution, but I'm not sure why it works.

I added a TCL Reset (Esc-E) to the start of the _HOLD_ file and it printed properly.

If anyone has any thoughts as to why this would matter, please let me know.

precisonline

  • President
  • Administrator
  • Rock Star
  • *****
  • Posts: 1612
    • Precision Solutions
Re: HOLD vs Direct Printing under RedHat Linux
« Reply #2 on: February 20, 2014, 09:41:12 PM »
The PCL reset certainly shouldn't be required. Did you do an od -tc on the _HOLD_ file to verify that the PCL commands were in there?
-Kevin
Accidents "happen"; success, however, is planned and executed.

Tom Pellitieri

  • Rock Star
  • *****
  • Posts: 224
  • Tom Pellitieri - Toledo, Ohio
Re: HOLD vs Direct Printing under RedHat Linux
« Reply #3 on: February 21, 2014, 12:52:15 PM »
Additional follow up ---

I sent a TCL report to the _HOLD_ file to make certain it wasn't going to be too big before I printed it.  When I spooled it to the printer, it came out with the default CUPS font, instead of the font I thought we had set up for the printer (!)

When I set up our RedHat system, I had trouble finding the options on the lp command to process the documents correctly.  I found the lpr command had flags that would let me print without filtering, which is what I needed.  I changed the defaults for UniData so the SETPTR command would use lpr.

Well, I found out that the (Prelude) program we use to spool from the _HOLD_ file uses lp, not lpr.  I changed the program to use lpr and it now appears to work correctly.

...<sigh>...