Precisely Speaking

Application Support => Prelude Support => Topic started by: CKilgore on February 10, 2010, 08:33:09 AM

Title: Bug in /UAI - Usage Audit Inquiry
Post by: CKilgore on February 10, 2010, 08:33:09 AM
I recently came across this bug in Prelude code.  I'm not sure if this is unique to our setup or not.

When looking up product usage in /UAI (or /PMM > F5 > F7), it throws an error that year 2010 is invalid.  I traced the problem back to the Field Definition for WK.YEAR in the USG.AUDIT.XREF file.

The validation code was:
R:00 TO 09 OR R:2000 TO 2009{[U2]}

I changed the validation code to:
R:01 TO 10 OR R:2001 TO 2010{[U2]}

After making this change, everything began working again.
Title: Re: Bug in /UAI - Usage Audit Inquiry
Post by: Tom Pellitieri on February 10, 2010, 02:23:45 PM
Hey there!  Welcome!

Field WK.YEAR in USG.AUDIT.XREF was last updated for Version 16.  The validation code change you made will work until you try to enter 2011.

Personally, I would update the limits to 20 and 2020, respectively, and report the bug and temporary fix to Activant.  It will be something to check on the next upgrade to see if it was fixed.

--Tom
Title: Re: Bug in /UAI - Usage Audit Inquiry
Post by: CKilgore on February 10, 2010, 02:32:49 PM
Tom

Was this same validation code on your system?

Bumping it only a year was just a short term fix.
Title: Re: Bug in /UAI - Usage Audit Inquiry
Post by: Tom Pellitieri on February 10, 2010, 03:04:04 PM
Yes... the validation code was only for 2000-2009... (sigh)

--Tom
Title: Re: Bug in /UAI - Usage Audit Inquiry
Post by: precisonline on February 10, 2010, 03:17:43 PM
Someone should post that over to the IPUG.  But then again, that's just me. :)
Title: Re: Bug in /UAI - Usage Audit Inquiry
Post by: CKilgore on February 10, 2010, 03:36:05 PM
Someone should post that over to the IPUG.  But then again, that's just me. :)

I would if I could, but I can't.  I haven't been allowed into that party yet.
Title: Re: Bug in /UAI - Usage Audit Inquiry
Post by: CKilgore on February 10, 2010, 04:21:51 PM
Prelude is aware of this.

Per Brent:
Quote
Chris,
This is a known bug that David is aware of, he asked that all   
cases related to this issue go directly to him to be fixed.   
Title: Re: Bug in /UAI - Usage Audit Inquiry
Post by: davidkyles on February 13, 2010, 07:09:46 AM
v21 has been fixed... at least until the year 2030.